Reply
 
Thread Tools Display Modes
Old 01-16-2005, 07:26 PM   #1
amy
Administrator
Site Admin
 
amy's Avatar
 
Join Date: Nov 2004
Location: Western Massachusetts
Posts: 3,783
Thanks: 348
Thanked 737 Times in 157 Posts
Media Player seems to be quirky with some videos
It's been brought to my attention, and I've confirmed this, that some videos are acting quirky in Media Player. I'm not sure if it's just a few or most videos.

What's happening is that when you play the video for the first time, it cuts off before finishing. But if you close the window and try the video a second time, it works and plays all the way through, no problem. The video will work fine from then on, unless you clear your cache, then you'll have to play it twice again. A couple examples of this are the SSP videos on the decrease page.

If anyone figures out a solution for this, please let me know! It seems to be browser-related, because the original files that are on my computer play fine in Media Player, and I've uploaded them twice. It seems that Media Player only acts up when used online, via Internet Explorer (possibly other browsers too).

Is this happening to people? Do you know if it's a lot of the videos, or just a couple? For now, until a solution presents itself, I am recommending people view the videos in Quicktime. Although it's certainly possible to use Media Player still, just occasionally annoying. ...It's most bizarre!

Amy
__________________
~Amy
KnittingHelp Queen Bee


‎"There is a vitality, a life force, an energy, a quickening that is translated through you into action, and because there is only one of you in all of time, this expression is unique. And if you block it, it will never exist through any other medium and it will be lost. The world will not have it. It is not your business to determine how good it is nor how valuable nor how it compares with other expressions. It is your business to keep it yours clearly and directly, to keep the channel open. You do not even have to believe in yourself or your work. You have to keep yourself open and aware to the urges that motivate you. Keep the channel open."
Martha Graham
amy is offline   Reply With Quote
Old 01-16-2005, 08:42 PM   #2
beldaraan
Working the Gusset
 
beldaraan's Avatar
 
Join Date: Jan 2005
Location: Alberta, Canada
Posts: 1,527
Thanks: 34
Thanked 98 Times in 18 Posts
I've had this happen a couple times although I couldn't really say which videos. It might have been for longer ones. I sort of understand what is happening, but would never in a million years be able to explain it or solve it.

I will ask my hubby and see if he knows anything off the top of his head.
beldaraan is offline   Reply With Quote
Old 01-16-2005, 09:42 PM   #3
beldaraan
Working the Gusset
 
beldaraan's Avatar
 
Join Date: Jan 2005
Location: Alberta, Canada
Posts: 1,527
Thanks: 34
Thanked 98 Times in 18 Posts
Ok, back with a few suggestions:

Here's a little explanation of what is probably happening. When you load a video it needs to buffer itself. The buffer collects and holds the video data so that others can view it. The default setting in Windows Media Player (WMP) will allow you to watch the video while it is still buffering. Sometimes the video will catch up to the buffer. When this happens that meas that WMP hasn't finished collecting the data from your website while someone is trying to watch it, so it will either stop or sometimes get a "lag" to it (re-buffering - meaning WMP kind of stalls on the last frames until more data gets there).

Part of this problem could be on your end and part of it could be on the default settings in WMP on our end.

One issue could be network congestion. This means that there is not enough bandwidth to stream your videos. If your bandwidth is slow, then that could be the issue. On the other hand, if our bandwidth is slow through our internet service provider (ISP) then it is our problem and we have to make changes in WMP settings.

There are 2 different settings in WMP that we can change. The first one is to change the buffer size. Changing the buffer size means that it will buffer for a certain amount of time before playing the video. The other setting is to change the connection speed from the default to a lower one than what you're using.

Ok, so how the heck does one change these settings?! Here we go...

1) Change User Default Buffering (UDP)

--Open WMP in full window mode instead of compact mode.
--Right click on the top "bar" of the player to get a menu.
--Click Tools-->Options-->Performance
--Under Network Buffering click on Buffer and type in 30 (this means it will buffer for 30 seconds before starting the video clip.) You could try 10 or 20 seconds to see if this works.
--Click Apply and then OK
--Close WMP and then re-open it and watch your video

2) Change Connection Speed

--Open WMP in full window mode instead of compact mode.
--Right click on the top "bar" of the player to get a menu.
--Click Tools-->Options-->Performance
--Under Connection Speed, click the button beside "My connection speed is"
--Click the speed that is one or two speeds lower than what you are currently using.
--Click Apply and then OK
--Close WMP and then re-open it and watch your video

So, that's it. I hope this wasn't information overload. Amy, maybe you can just put on a recommendation to change these settings. As I suggested in my previous post, I think it happens with the larger video files. If you're using high quality, that might be part of the problem.
beldaraan is offline   Reply With Quote
Old 01-17-2005, 12:18 AM   #4
amy
Administrator
Site Admin
 
amy's Avatar
 
Join Date: Nov 2004
Location: Western Massachusetts
Posts: 3,783
Thanks: 348
Thanked 737 Times in 157 Posts
Wow Beldaraan, thanks for the info. I'm sure there are people with slow connections that will find that useful.

The problem I'm talking about, however, is definitely not a buffering problem. It's happening with Cable modems, and with DSL connections, on even the smallest videos, and it's consistent and doesn't continue to play when you wait. There's also the strange fact that it only happens the first time you view it. ...Bizarre, I know!

Thanks so much for that info though. I really appreciate your work, and, again, that is great info for people who are having the buffering problem--I'm sure those folks are out there too!

Thanks!
Amy
__________________
~Amy
KnittingHelp Queen Bee


‎"There is a vitality, a life force, an energy, a quickening that is translated through you into action, and because there is only one of you in all of time, this expression is unique. And if you block it, it will never exist through any other medium and it will be lost. The world will not have it. It is not your business to determine how good it is nor how valuable nor how it compares with other expressions. It is your business to keep it yours clearly and directly, to keep the channel open. You do not even have to believe in yourself or your work. You have to keep yourself open and aware to the urges that motivate you. Keep the channel open."
Martha Graham
amy is offline   Reply With Quote
Old 01-17-2005, 01:38 AM   #5
beldaraan
Working the Gusset
 
beldaraan's Avatar
 
Join Date: Jan 2005
Location: Alberta, Canada
Posts: 1,527
Thanks: 34
Thanked 98 Times in 18 Posts
Ok, I get it now. I checked it out and did a little experiment on the decrease SSP video. Here's what I did (btw, this first part was done using IE):

1) Opened the video, watched it to the end, closed WMP, opened again. First video was 9 seconds, and the second time it was 18 seconds.

2) closed all my windows, and went to same video. Started as 9 seconds again.

3) Stayed at your website and just closed WMP, after watching it full the first time. Always got 18 seconds after that as long as I didn't close your website.

4) Opened your video, got 9 seconds. Closed it right away and tried opening it again. Got 9 seconds again. (Thought this might have been a shortcut to find the other videos that do the same thing, but no go. You have to watch it the first time and then close window, then re-open and look at the time to see if it's the same).

Clearing out all of my cookies and internet files didn't help.

My other experiment involved using a different web browser. I've been meaning to put it back on my computer anyway, so I downloaded and installed Mozilla Firefox. I got the full 18 seconds each time attempting all of the above experiments.

Any Netscape users to join in on this experiment?

Amy, not that this would be your idea of time well spent or fun, but if it's only certain videos, then maybe re-shoot them? Perhaps the video is somehow corrupted.

I'll keep doing my experiments on the other videos with IE. I have a few theories that might put some insight into the problem. I thought maybe it was videos with just sound. Or maybe WMP cuts the video in half when it pulls this stunt on your videos. Not that this would help solve it, but maybe if it's always cutting the video in half or cutting after 9 seconds, it might help narrow down.

I'll keep you posted.
beldaraan is offline   Reply With Quote
Old 01-18-2005, 09:47 AM   #6
Cellcept
Casting On
 
Cellcept's Avatar
 
Join Date: Nov 2004
Location: Omaha, NE, USA
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to Cellcept
Hmmm, I dont have any any of these problems with the videos, particularly the SSP, but then again I dont play videos within IE. All the videos play entirely without stopping, which to me says they are not corrupted. I use Open and then WMP plays it or I will Save As and watch them that way.

Rick
__________________
"I expect to pass through this world but once; any good thing therefore that I can do, or any kindness that I can show to any fellow-creature, let me do it now; let me not defer or neglect it, for I shall not pass this way again." - Stephen Grellet
Cellcept is offline   Reply With Quote
Old 01-27-2005, 12:37 PM   #7
kikicorm
Casting On
 
Join Date: Jan 2005
Location: sault ste. marie ontario
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to kikicorm Send a message via MSN to kikicorm Send a message via Yahoo to kikicorm
i am glad to see that it isnt only happening to me,,,lol
__________________
kikicorm is offline   Reply With Quote
Old 01-27-2005, 12:56 PM   #8
amy
Administrator
Site Admin
 
amy's Avatar
 
Join Date: Nov 2004
Location: Western Massachusetts
Posts: 3,783
Thanks: 348
Thanked 737 Times in 157 Posts
We've been trying EVERYTHING, and we think we may finally be getting somewhere.... We think that it's the video editing program I've been using (Sony Vegas Movie Studio 4.0), which has been making the videos cut off and stop playing before they're done in Media Player.

We've tried changing a zillion settings in that program, and nothing has helped. Finally, I ran a new video through another program, and it worked! ....Now I just have to see if I can run the corrupt videos through this program to get them to work.... I sure hope so, because otherwise I WILL have to re-shoot them, and some of them are quite long!

Cross your fingers for me!
Amy
__________________
~Amy
KnittingHelp Queen Bee


‎"There is a vitality, a life force, an energy, a quickening that is translated through you into action, and because there is only one of you in all of time, this expression is unique. And if you block it, it will never exist through any other medium and it will be lost. The world will not have it. It is not your business to determine how good it is nor how valuable nor how it compares with other expressions. It is your business to keep it yours clearly and directly, to keep the channel open. You do not even have to believe in yourself or your work. You have to keep yourself open and aware to the urges that motivate you. Keep the channel open."
Martha Graham
amy is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Knit a cozy with strap for an mp3 player. chocogirl Pattern Central 2 12-20-2007 12:07 AM
How knitting has made me a better guitar player The Spider General Knitting 16 10-06-2006 01:27 AM
How knitting has made me a better guitar player The Spider General Knitting 0 10-03-2006 11:58 PM

All times are GMT -4. The time now is 06:15 AM.